Spatial Cloud - ANZ Region - 2022B / 2023B Release
Incident Report for TechnologyOne
Resolved
Incident Resolution and Root Cause Analysis

We are pleased to inform you that the recent service incident has been fully resolved.

Root Cause:
Upon initial analysis, it was determined that the incident originated from an unexpected anomaly within our primary storage volume. This anomaly disrupted standard operations and access to crucial database services. Although the secondary volume remained operational and helped prevent a complete service outage, the issue with the primary volume required immediate intervention to ensure the continuity of our services.

Service Restoration Actions:
To mitigate the impact and fully restore services, our technical team promptly initiated a failover process. This process involved transitioning the operational nodes from the primary to the secondary system and then back again, to ensure thorough resolution. This failover was meticulously executed twice—from System A to System B and back, and then from System B to System A and back—to guarantee a comprehensive restoration of services. Despite a brief service interruption during this process, our team made every effort to minimize the downtime and quickly return to normal operations.

Further, we have proactively engaged with our upstream providers to investigate the cause of the anomaly within our storage services. This inquiry aims to uncover the root cause of the disruption and to identify and implement the necessary preventive measures to prevent future occurrences.

We are committed to continuous improvement and ensuring the reliability of our services. We appreciate your understanding and apologize for any inconvenience this may have caused.
Posted Mar 13, 2024 - 11:39 AEST
Monitoring
A fix has been implemented and we are currently monitoring the services for stability. Details of the root cause will be shared prior to resolving this incident.
Posted Mar 13, 2024 - 08:36 AEST
Identified
Our engineers have identified the cause of the incident and are currently working towards addressing the issue. This is to ensure spatial services are restored to standard operation levels.
We shall aim to provide the next update within the next 60 minutes.
Posted Mar 13, 2024 - 08:14 AEST
Investigating
We have identified an issue with some customer environments experiencing connection issues and performance degradation within CiAnywhere / ANZ Region / 2022B & 2023B Release.

Our engineers are currently investigating the root cause. Further updates will be provided.

We apologise for the inconvenience caused.
Posted Mar 13, 2024 - 07:23 AEST
This incident affected: Software as a Service - Australia & New Zealand (Spatial Cloud).