DP Service Degradation - All Regions / All Release
Incident Report for TechnologyOne
Postmortem

TechnoiologyOne apologies for the inconvenience this event caused our customers. At TechnologyOne we work in a CI/CD operational mode, as such a software change was introduced into the DP service causing DP jobs, not to process.

Our monitoring platform alerted the team of the problem and a rollback of the change was put in place in a short period of time.

We have reviewed our change management process and implemented a change whereby critical service layer updates will only be actioned outside of the 8.30 am - 5.00 pm window.

Posted May 23, 2022 - 10:35 AEST

Resolved
This incident has been resolved.
Posted May 04, 2022 - 14:34 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2022 - 12:18 AEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 04, 2022 - 11:57 AEST
Investigating
We have identified a selection of customer environments experiencing DP service degradation within all SaaS releases.

Our engineers are currently investigating the root cause.
Posted May 04, 2022 - 11:57 AEST
This incident affected: Software as a Service - United Kingdom & Europe (Batch Services (DP Jobs)), Software as a Service - GovCloud Australia (Batch Services (DP Jobs)), and Software as a Service - Australia & New Zealand (Batch Services (DP Jobs)).