Email Delivery Delays
Incident Report for TechnologyOne
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 29, 2019 - 21:35 AEST
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jul 29, 2019 - 19:05 AEST
Monitoring
O365 email delivery is now flowing.

Backlogged email is also processing
Posted 3 months ago. Jul 29, 2019 - 19:03 AEST
Investigating
Some customers who use O365 are currently experiencing delays in email delivery

We are currently investigating the issue and will provide a further update shortly
Posted 3 months ago. Jul 29, 2019 - 18:09 AEST
This incident affected: Software as a Service - GovCloud Australia (E-mail Services), Software as a Service - United Kingdom & Europe (E-mail Services), and Software as a Service - Australia & New Zealand (E-mail Services).