Intermittent 502 and Service Unavailable Errors for a subset of customers in ANZ Region on 2025A

Incident Report for TechnologyOne

Resolved

The permanent fix for the intermittent 502 and Service Unavailable errors in Financials and Supply Chain functions was deployed to Mainline Snapshot 2025A (394).

Following monitoring through to Monday, 30 June, no further issues have been observed. This incident is now considered resolved.

Thank you for your patience while we worked to address the issue.
Posted Jun 30, 2025 - 17:16 AEST

Update

The permanent fix for the intermittent 502 and Service Unavailable errors in Financials and Supply Chain functions will be deployed to Mainline as Snapshot 2025A (394). according to the planned schedule. Schedule can be found here: https://technologyonecorp365.sharepoint.com/:x:/s/SP_KT43N9/EeB5USzWQRRKhWmWvKnzamsBriu6Zd7TgMHnrwONTJQN9w?e=zVJ6FX

We will continue to monitor through Monday, 30 June, to ensure stability.

Further updates will be provided if required.
Posted Jun 26, 2025 - 09:11 AEST

Update

The permanent fix for the intermittent 502 and Service Unavailable errors in Financials and Supply Chain functions will be released to Fastline this evening 2025A (394).
The fix will be included in Mainline as part of the scheduled update next weekend. You can view the deployment schedule here - https://technologyonecorp365.sharepoint.com/:x:/s/SP_KT43N9/EeB5USzWQRRKhWmWvKnzamsBriu6Zd7TgMHnrwONTJQN9w?e=zVJ6FX
We’ll continue to monitor and will provide confirmation once the Mainline update is complete.
Posted Jun 20, 2025 - 09:28 AEST

Monitoring

Mitigations have been applied and are currently being monitored to ensure stability and reduce further impact. A permanent fix remains in development.
We’ll provide an update once the fix is available or if anything changes. Thank You for your patience.
Posted Jun 19, 2025 - 09:51 AEST

Identified

We’ve identified the exception pattern causing intermittent 502 and Service Unavailable errors in Financials and Supply Chain functions.
A permanent fix is now under development, and mitigations remain in place to reduce impact in the meantime.
We’ll provide further updates as the fix progresses.
Posted Jun 18, 2025 - 16:59 AEST

Investigating

We’re currently investigating ongoing 502 and Service Unavailable errors affecting some environments following the recent Mainline update (Snapshot 2025A (380)).
These errors are currently observed in Financials and Supply Chain functions. They are linked to exceptions triggered by specific user actions, which cause the affected service to shut down. TechnologyOne is actively remediating as incidents occur.
Mitigations have been implemented to reduce the impact while we identify the exception pattern and develop a permanent fix.
We will provide an update as soon as more information is available.
Posted Jun 18, 2025 - 12:55 AEST
This incident affected: Software as a Service - Australia & New Zealand (Ci Anywhere).